[solved] SMS to users inbox NOT captured to user inbox

I have a user MOH, when send message to @MOH sometext the message does not to the user inbox.
Checking in the sandbox the message received becomes >> imoh sometext
It seems that the ‘@’ is chaged to ‘i’

Im using Kannel 1.4.4 and playsms 1.3

Any idea how to resolve this please

ps: I have done the following as per doc/example

Please visit Settings->Route incoming SMS and enable to scan @username and #groupcode

And then enable the forward on each account.

Any help on this pls?

Finally I resolved this after debugging the incoming SMS from kannel which is differently encoded for the character ‘@’.
My system

  1. kannel 1.4.4 connecting to telco SMPP
  2. playsms 1.3.1

add alt-charset = utf-8 in the kannel config for the smpp smsc

refer soln from http://www.kannel.org/pipermail/users/2012-April/017721.html