[solved] Problems with installation


I am having the following problem and it is driving me nuts.

I am on ubuntu 12.04 LTS.
I have just downloaded the master version from github and followed the instructions with installation script.
Evertyhing worked smoothly, no problem. I have installed on /var/www/xpml/httpdocs and updated install.conf
PLAYSMS_PATH = /var/www/xpml/httpdocs.
PLAYSMS_LIB = /var/lib/playsms
PLAYSMS_BIN = /usr/local/bin
PLAYSMS_LOG = /var/log/playsms
PLAYSMSD_CONF = /etc/playsmsd.conf

installer worked ok. Composer installed and updated correctly and playsmsd is running.I have doubled checked it.

When i try to login, i see the login screen but when I enter admin:admin nothing happens. The page stays there on log in screen and doesn’t let me logged in. Even if I click on forgot password, the url is changed to “index.php?app=main&inc=core_auth&route=forgot” but i keep seeing the login screen
I have checked the logs and found only this xpml 2015-07-07 10:28:34 PID559b7fa2538ce admin L2 auth_block # WARNING: no access or blocked. sid:f07b34tokpaojv5kuqraackmq1 ip: uid:1 app:main inc:core_auth op:block route:block xpml PID559b807e85379 - L2 init # WARNING: possible CSRF attack. sid: ip:

of course i made sure that i am not blocked by firewall, etc.

I guess it might be a permission issue, but I am not sure which permissions I should change. I have follwoed the installation script and haven’t changed any other permission by hand.
/var/www/xpml/httpdocs - www-data:www-data - 755 (and recursively all folders under httpdocs are 755)

the logs are not helping me much, i have installed and re-installed 4 times and I am always stuck at this point.

try exit the browser, kill the browser and start again (browse again)


Hi Anton,

Thanks for helping.

I have already done that.
Still I am having the same problem. Any other idea where should I search?

i have same problem.
After instalation i can’ t login by admin:admin

In log file i found this: 2015-07-16 08:53:42 PID55a77116b5387 - ip: app:main inc:core_auth route:login op:login 2015-07-16 08:53:42 PID55a77116c0352 - ip: app:main inc:core_auth route:login

P.S. Don’t matter what login/password did you wrote.
The same line in log file

app:main inc:core_auth route:login op:login


I haven’t found a solution. I have installed and reinstalled playsms almost 7 times and used almost all versions.
The reason this happened to me is because i have updated(apt-get update) my ubuntu and something messed up most probably with permissions. And I am not talking about playsms permissions. Something, somewhere else… You need to debug to find out exactly why.
Last hope was to restore an older backup of the whole server (not playsms).
Fortunately, this worked out and then i was able to install version 1.1 with no problems.

Hope it helps someone else too

in playsms/index.php file i’m wrote:


echo $_POST['username'];

and when i press logon button, i’v get only one string asdasda.

SOLVE this problem by:

  1. Remove php and all modules
  2. Remove httpd (apache)
  3. yum clean all && yum update
  4. Then install httpd and php with required modules

mysql database and already installed playSMS in /var/www/html/playSMS i don’t touch