[solved] Default SMSC for replies from SMS custom

Hello all,
I am using smsservertools3 and playSMS1.3.1

The replies from SMS custom are using an SMSC name i don’t have configured in playSMS, and as a result, the reply texts are stuck in ‘pending’. The SMSC name being used is similar to the modem name in the file smsd.conf.

How do i choose the SMSC to be used by SMS custom when replying users?

when sending SMS, not replying, was the message sent ? (status green/blue)

just checking if its actually because of SMSC or some other misconfiguration or error


I have a similar problem with kannel , this was working before not sure what changed.

My problem is when I simulate everything is OK and it uses dev as the SMSC.
When I send a normal message is uses kannel which is the only SMSC I have defined.
When I use use custom it uses SMSPRO which is my bind in my kannel setup I cannot figure out what the problem is.
See attached fist one is the one failing the second is the simulate incoming and the 3rd is a normal message.

This is my Custom URL

The only place I see SMSPRO is my connection to my SMPP server.

Hi Francis have you sorted this out I have a similar problem but with kannel see my post.

Yes, I am also going through with similar problem while sending SMS

Is this also related to Custom or just general sending ?

Anton please have a look at my post, I have been battling with this for a while now and I see its not only me.

No the message is not send status yellow because its picking a SMSC that is not configured.
Please check this for us.

Hi Francis have you made any progress on this ? This feature used to work as documented now I have the same problem, choosing an SMSC that is not configured but the name of the BIND to my upstream SMPP conection.

Hi Francis have you sorted out this problem ?

Francis I cannot get the Make return as reply to work so used web services instead.

Hi Steven,

Could you post new topic instead, I’m interested in debugging the issue right now, if its still an issue that is.


Hi Anton its only the “Mark return as reply” that’s not working so its not a big problem just used web services with curl for the reply.
Its kinda weird as the script will return the correct data but it chooses an gateway that does not exist but is the name of the gateway that you are binding to.

can you provide me with log ?


Please find attached logfile , the smsc:SMSPRO is incorrect and not defined anywhere.
The smsc:kannel is the correct one and is defined in the config section.
SMSPRO is the smsc I am connecting to.playsms.log (15.7 KB)


The log is in L2, need an L3. Can you paste your Kannel get-url URL (mask the IP/hostname) ?


Hi Anton here is my get url in kannel and the log file.playsms.log (5.9 KB)

get-url = “http://localhost/index.php?app=call&cat=gateway&plugin=kannel&access=geturl&t=%t&q=%q&a=%a&Q=%Q&smsc=%i

ok, it seems the default policy for picking SMSC is “supplied SMSC”.

2 things I would change:

  1. To ignore supplied SMSC from gateway (in this case supplied by smsc=%i) if that SMSC does not exists in playSMS
  2. To add options to select SMSC on SMS custom just like in SMS poll


I think option 2 will be the way to go thanks Anton.

heres the changes for SMS custom: