[solved] ACL issue after "&"

Any solution for https://groups.google.com/forum/#!topic/playsmsusergroup/fqyF5oElg84?


I just fixed this, it will be in 1.2. If you need now then you have to make changes your self, here:


1 Like

It works, Thank you Anton,

Anton Is this fixed now.I need to disallow user configuration only,but it applies user preference too.


Yes its fixed since 1.2


I don’ think its working fine.when I see the db & was in dlthe db.I checked php script its ok according to your fix.When I manually add from db also not working the ACL well.I want to disable user configuration for subuser but it applies to user preference too.
Could you please ensure I with your version.

well the OP said its working

what exactly did you add ? pls explain in detail, perhaps with screenshots


Please find the attached snapshot of my ACL List and data in the DB.

Now I cant see user config and user preference under menu.


Here is manage ACL, in your setting try to edit & to just &, it looks like config from an old version:

I have created acl NOUSERACL and apply it to user1:

Then I logged in as user1, as you can see no user config, as expected:

Its working fine by editing the db in backend.GUI still adds the &. My php code is correct according to a fix.

Thanks very much for graphical demonstration. :smile:


thats the thing, I dont experience that, when I add inc=core_user&route=user_config&op=user_config I didnt get inc=core_user&route=user_config&op=user_config, all looks normal to me

if you still see them, it must be something wrong. but then again, all is well so far, right? :slight_smile: until next bug