No message in inbox but in sandbox + autoresponde configuration

Good morning @All
I have install Playsms 1.3.1 + SmsTools3 3.1.15 on Raspberry PI2 (fantastic!!!)
I have 2 questions
SMS messages do not arrive in the inbox but in the sandbox, how can I fix it?
my configuration is
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
modem1 = /var/spool/sms/modem1

and PlaySms
Manage gateway and SMSC>gateway>Gateway SMS Server Tools 3>/var/spool/sms
Manage gateway and SMSC>SMSCs>smstools>/var/spool/sms/modem1

Let me know if you can configure any SMS arrivals to be answered automatically with a "default"
How should I set the autoresponde? (Version 2)


Hi David,

  1. My installation does that as well, however they do show up in the table playsms.playsms_tblRecvSMS

  2. First you must make sure that your SMStools is configured to accept incoming. Then if you want to autorespond to every inbound message you can set the autoresponder as follows: (btw make sure you are using the autorespond plugin, not the autoreply).

Service: whatever you want to call it.
Regex: /^(.*)$/
Respond Message: whatever you want the return SMS to say.
User: admin
Receiver Number: I left this empty
SMSC: Supplied SMSC (so that the reply doesn’t come from a different modem if you have more than one)

Note on the regex: the supplied regex will trigger an autoresponse on any non-blank incoming SMS. If you wish to filter for certain words or exclude certain words, you must create a regex for that. See for help.

One last caveat: If your autoresponder gets into a loop with another autoresponder (for example a number that cannot receive texts and sends a message), your PlaySMS can get into a SMS loop that could prove to be costly for you. For that reason my regex is not fully inclusive, it looks for the word ‘blocking’ in the incoming SMS and will ignore it instead of responding.
e.g./^((?!Blocking).)*$/ instead of /^(.*)$/

Hi Scott,
thanks for your reply.
SMStools is configured to accept incoming, the sms arrived but in Report>Sandbox not in Inbox.
Can you help me?

I can try your configuration for for autorespond now is perfect!!!

I don’t really know why it does that, perhaps it is a bug. Sorry I can’t be more help.

Sandbox means that playSMS was not able to determine rhe recipient. Based on which information the SMS should be sorted into a user’s inbox?

Hi Andre,
can you help me to setting correctly?
I have tried this, but now text messages do not come in the sandbox, do not come in inbox.
Please tell me the correct setting of “Route incoming SMS” and setting to mach user’s inbox

the easiest way to route to a user’s inbox is to use “@” in the sms. e.g. your username is “david_c” and the sms contains “@david_c” the sms will be forwarded to your inbox. but to be honest i am not quite sure if there is a configuration parameter that may change the behaviour. i have to look on monday at work.

@andre @scott @David please help i can send sms via playsms buti can’t receive any sms in the inbox or the sandbox I cofigured the route incoming SMS but no sms received
PS:i use kannel sms gateway and Samsung android phone (SMSC)
heeeelp :’(

is the sms received by your gateway? please check kannel log. i am using sms server tools, there i can see in logs when sms have been received.

thank you @andre for replying to me :slightly_smiling:
No the sms is not received by my gateway i only can send sms throught sms gateway
In my case i use kannel but infortually i can not see any sms received in kannel even in the log file :frowning:
could be the problem in my phone (problem of compatibility )
becasue in my case i use a mobile phone (Samsung galaxy S2 ) to test the sms gateway not a modem like wavecom ?
thank you :slight_smile:

well, in sms server tools i can configure if sms only to send or to receive as well. if reception is enabled, sms are fetched from provider. so have a look at your kannel config first. maybe someone else can help here, because i have no clue about kannel.