[solved] Credit ans SMS sending Issue

Hi I have installed playSMS 1.4.3 with gammu in my Ubuntu 18.04LTS server. Gammu is configured and playSMS is installed successfully. I have two issues as followed bellow-

  • Even I applied credit it does not appear to be applied for the user.
  • SMS does not get broadcast even everything is working fine.

Check your playSMS daemon. Credit will be added to user and SMS will be delivered when playSMS daemon working properly.

Make sure you have enabled log level 3 in config.php, restart playSMS daemon and watch the log while doing the test, for example when sending SMS.

Succesful SMS delivery should be logged like this:


I see you have sets log state to 3, make sure you have restart playSMS daemon.

And then, see where playsms.log is, according to your playsmsd.conf, playsmsd.log should be in /var/www/html/log

do this before test sending SMS:

tail -f /var/www/html/log/playsms.log | tee test1.txt

And then send SMS, after that ctrl+C the tail command above and see test1.txt

paste, or screenshot that test1.txt content here


Dear Anton

How to restart playSMS daemon?
Log is located in /var/www/html/log/playsms.log file

/var/www/html/bin/playsmsd /var/www/html/etc/playsmsd.conf restart

I suggest you follow this manual to the letter for practice:


Have you route outgoing SMS to gammu ?

See Settings → Manage gateway and SMSC, add SMSC gammu
And then Settings → Route outgoing SMS and route to SMSC gammu

Theres gateway, and theres SMSC, playSMS is using SMSC instead of the gateway, so you need to not just configure the gateway but also add SMSC.

SMSC derived from gateway, so you need to configure Gammu gateway and then create SMSC based on that. These are available from Settings → Manage gateway and SMSC.


Oh I see you have routed to SMSC gammu, missed that sorry.

What do you see in playsms.log ? See how to do the test above (with the tail command etc)


Can you show me a little bit more above it? I see dlrd shown us that p_status is 2, means send SMS with status failed.


If you like you can access my pc via anydesk. I dont get ‘little bit more above it’. I feel like you are asking to show terminal content little bit up.

Do the tail before sending SMS, and then ctrl C to get the file test1.txt. What should be in test1.txt when you do that is log of what happened during sending of SMS.

Why it failed, or any other problem, hopefully can be found in that log file.

Send to info@playsms.org the file test1.txt, or just send playsms.log if that’s ok with you.


From your playsms.log I saw this:

L3 gammu_hook_sendsms # enter smsc:gammu smslog_id:32 uid:1 to:+88xxxxxxxxxx
L2 gammu_hook_sendsms # saving outfile:[/var/spool/gammu/outbox/OUTA20210201_164906_00_+88xxxxxxxxxx_32100011100010.txtd] smsc:gammu
L2 gammu_hook_sendsms # fail to save outfile:[/var/spool/gammu/outbox/OUTA20210201_164906_00_+88xxxxxxxxxx_32100011100010.txtd] smsc:gammu
L3 dlr # isdlrd:1 smslog_id:32 p_status:2 uid:1
L2 sendsms_process # fail no hook for sendsms

This part:

fail to save outfile:[/var/spool/gammu/outbox/OUTA20210201_164906_00_+88xxxxxxxxxx_32100011100010.txtd] 

Make sure playSMS daemon have access to write to directory /var/spool/gammu/outbox


I have changed the permission of /var/spool/gammu folder and now it can be accessible for playSMS.

After changing the permission I tried to send a sms.
Before setting up permission I used to see a red indicator besides All sent messages queue.

Now its turned yellow and a file named OUTA20210202_81639_00_+8801712677228_33100011100010 has been saved automatically inside /var/spool/gammu/outbox folder.

But I didn’t receive any sms at desired number.

I feel like I am nearly touching my final output.

I hope Anton you are kind enough to help me to touch the touchline.

After that its Gammu time to handle the file, read the file and send SMS

playSMS job is to write a file to Gammu’s outbox directory to send SMS and periodically read Gammu’s inbox directory to read incoming SMS. The actual engine that deliver/receive SMS is Gammu.

The status yellow means Pending SMS, playSMS is waiting for the file processed by Gammu and moved to folder sent by Gammu.

So next, check on Gammu side, Gammu log etc.


I am stuck on that :

sudo gammu --identify
[sudo] password for mahedi:
Error opening device. Unknown, busy or no permissions.

Many thanks Anton for your support. I have successfully configured playsms and now sending sms to my clients.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.