[solved] Can't change language in user configuration

In upward screenshots we can see that can not change language to specification. downward menu don’t appear in user config menu and main config menu too.
Thank in advance!

Please help if anyone came across. Very high need for this is. Not everyone can use English. Surely this is a bug (but I do not know how things are with the others about changing the language).
Thanks in advanse.


Hi everyone!

How to active another than English language?
Thanks in advance.


Its loaded, but not active, you can change language from My account -> User configuration or globally from Settings -> Main configuration -> Default site configuration.

You need to also install language pack in the server. Example to enable Bahasa Indonesia:

sudo apt install language-pack-id


Anton, I would like to draw your attention to one more incomprehensible behavior: We discussed this moment with you. But I want to emphasize that localectl list-locales provides all the necessary language support. But at the same time, if they are not shown in the list (as seen in the screenshot).



php 7 stuffs

Thank you so much, Anton. Topic is closed.

Jamshid Tursunov


With playsms 1.4.3 running well on a PI, I cannot change interface to french

Plugin screen: FR is activated
and config is set to FR

What can I do ?

Try this, but for fr:


I of course activate it for user and also default settings.

language-pack-fr does not exist.

Via raspi-cnfig i installed

fr_BE.UTF-8… done
fr_FR.UTF-8… done

no success, still english

Thank you

In 1.4.3 all translations of languages files are empty
look at messages.po

msgid “1 Day”
msgstr “”

msgid “1 Month”
msgstr “”

msgid “1 Week”
msgstr “”

msgid “2 Days”
msgstr “”

msgid “2 Weeks”
msgstr “”

and so on…
modify the file does not work

you have to install gettext
get a copy of the .po files from 1.3.1 and replace your file
run contrib/tools/language//update-1-2-3-4.sh

This will make new translation files